LCD works but dial doesn't

Troubleshooting talk for software

LCD works but dial doesn't

Postby Defy » 2014-Jun-Sat-22-Jun

So I installed my LCD screen and the rotary dial doesn't work? Is this firmware or do I have a bad part? It lets me see the first screen and then I can push the dial for the other screen but the rotary part doesn't work so I can't select anything else.... just keep pushing the button and toggling between screens???
  • 0

User avatar
Defy
Printing skirt...
 
Posts: 155
Joined: 2014-May-Sat-14-May
Location: Omaha
Reputation: 6

LCD works but dial doesn't

Sponsor

Sponsor
 

Re: LCD works but dial doesn't

Postby evanalmighty » 2014-Jun-Sun-01-Jun

I believe it's the firmware. Check towards the bottom of config.h where all the settings for the LCD are.
  • 0

User avatar
evanalmighty
Layer 650 of 1234
 
Posts: 689
Joined: 2014-Feb-Mon-15-Feb
Location: Irvine, CA
Reputation: 45

Re: LCD works but dial doesn't

Postby Defy » 2014-Jun-Sun-11-Jun

I dont have a .h i just get the hex file which i assume is the compiled version.
  • 0

User avatar
Defy
Printing skirt...
 
Posts: 155
Joined: 2014-May-Sat-14-May
Location: Omaha
Reputation: 6

Re: LCD works but dial doesn't

Postby evanalmighty » 2014-Jun-Sun-11-Jun

Hmmm... That's above my pay grade. I've only worked with the raw codes and the Ramps board. Never had to mess with printrboard.
  • 0

User avatar
evanalmighty
Layer 650 of 1234
 
Posts: 689
Joined: 2014-Feb-Mon-15-Feb
Location: Irvine, CA
Reputation: 45

Re: LCD works but dial doesn't

Postby Defy » 2014-Jun-Sun-18-Jun

Thanks anyways. I will fuss with it.
  • 0

User avatar
Defy
Printing skirt...
 
Posts: 155
Joined: 2014-May-Sat-14-May
Location: Omaha
Reputation: 6

Re: LCD works but dial doesn't

Postby Defy » 2014-Jun-Mon-19-Jun

Anyone got the lcd working with the metal?
  • 0

User avatar
Defy
Printing skirt...
 
Posts: 155
Joined: 2014-May-Sat-14-May
Location: Omaha
Reputation: 6

Re: LCD works but dial doesn't

Postby diwatsuki » 2014-Jul-Mon-14-Jul

Yes, mine came up just fine (I have an early Simple Metal kit with a Rev D printrboard running
the FW that was on the printrbot site in May (it was labled "V3", but loads as "V1 with updates")

BTW, GitHub has a new release for the "Model 1403" that was updated at end of June;
I'll try switching to that at some point)

I was a little confused by the on-line instructions as to which way the cable goes on since I usually assume the red wire is for Pin 1.
Turns out they flipped both ends when they connect to the LCD and the printerboard.
(I added my comments to their on-line document).

At initial power on I get an info menu with temperatures and turning the knob varies the extrusion factor from the default 100%.
Pressing the knob takes me to a set of menus I can scroll through by turning the knob and then selecting by pressing on the knob.

I can do things like home or move the head, heat up the extruder, and best of all, select gcode files off the SD card
(no need to name them 'auto0.g' anymore!!)

I haven't tried sending messages to the LCD from commands within gcode yet, however.
  • 0

diwatsuki
Waiting to connect to printer...
 
Posts: 5
Joined: 2014-Jul-Mon-14-Jul
Reputation: 0

SOLVED: Re: LCD works but dial doesn't

Postby Defy » 2014-Jul-Tue-20-Jul

Got it working after PB sent me a replacement LCD and I still had the same issue I then checked the cable and that did the trick. Now I have a working LCD screen with the Metal. Now I need to design a case to mount it to my Metal... any ideas
  • 0

User avatar
Defy
Printing skirt...
 
Posts: 155
Joined: 2014-May-Sat-14-May
Location: Omaha
Reputation: 6

Re: LCD works but dial doesn't

Postby Desdemona1 » 2015-Jun-Fri-00-Jun

Im using a ramps LCD and everything works but the SD feature, has any one experienced this issue?
1405 rev f4
  • 0

I think I'd like to do something nice for somebody. I think it's good if you smile at someone, and they smile in return. Voluntary love encourages people to create a sense of friendliness.
User avatar
Desdemona1
Levelling print bed...
 
Posts: 32
Joined: 2015-Mar-Wed-18-Mar
Location: Albany, NY
Reputation: 0


Return to Troubleshooting talk

Who is online

Users browsing this forum: No registered users and 0 guests

cron