Can't pronterface to board

Newbie talk about software tools, drivers, etc

Can't pronterface to board

Postby 3DSheffield » 2013-Apr-Tue-16-Apr

I have a printrbot LC. I have made it from files from thingiverse. I have a revision E printrboard. Windows XP instals the device and recognises it says it is installed correctly and functioning (serial install service pack 3.5 etc) but I cannot connect pronterface.

says connecting but doesn't

have set baud rate and see either COM3 or 4 depending on socket used.
PC is fairly old is this an XP problem or have I connected up something wrong.

Also there ared different flavours of USB odes this matter.
I am thinking of replacing with a Win7 laptop
Again does USB 3 work with this board

board was shipped assembled tested flashed with marlin LED lights under USB power
Have unsoldered USB power for now (LED lights under external ATX)
I have tried searching forums to now avail is there something obvious or a way to fault find

Many thanks

dave
  • 0

3DSheffield
Waiting to connect to printer...
 
Posts: 6
Joined: 2013-Jan-Thu-16-Jan
Reputation: 0

Can't pronterface to board

Sponsor

Sponsor
 

Re: Can't pronterface to board

Postby RetireeJay » 2013-Apr-Tue-16-Apr

Did you install the USB Serial driver?
http://pjrc.com/teensy/serial_install.ex

I have no idea why this has been dropped from the Getting Started Guide. It was there in the older version of the guide that I used in January. Now I wish I'd downloaded the guide... :(

Anyway, I've connected both an XP and a Win-7 computer to my 'bot with no problem.

USB3 is supposed to be completely backwards-compatible with lower-numbered versions, so I doubt that's a problem.

When you plug in your 'bot, then it should show up in Device Manager, something like this (from a Windows-7 screen shot). It's on the last line here, as "USB Serial (Communication Class, Abstract Control Model) (COM30).

DeviceManager.PNG


So in order to use it, I set the COM port in Repetier (or Pronterface) to 30. You will probably see a different COM port on your machine. Mine was different on the XP computer than on this W-7 computer.
  • 0

You do not have the required permissions to view the files attached to this post.
Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
"My next printer is..." Prusa i3 MK3, upgraded to MK3S
User avatar
RetireeJay
My next printer is...
 
Posts: 4999
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 498

Re: Can't pronterface to board

Postby PxT » 2013-Apr-Tue-16-Apr

RetireeJay wrote:Did you install the USB Serial driver?
http://pjrc.com/teensy/serial_install.ex

I have no idea why this has been dropped from the Getting Started Guide. It was there in the older version of the guide that I used in January. Now I wish I'd downloaded the guide... :(



For your convenience:
https://dl.dropboxusercontent.com/u/680 ... 0Guide.pdf
  • 0

User avatar
PxT
Print complete...
 
Posts: 1339
Joined: 2011-Dec-Mon-16-Dec
Location: Sacramento, CA
Reputation: 97

Re: Can't pronterface to board

Postby RetireeJay » 2013-Apr-Tue-19-Apr

Thanks, PxT! I've got it saved now.
  • 0

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
"My next printer is..." Prusa i3 MK3, upgraded to MK3S
User avatar
RetireeJay
My next printer is...
 
Posts: 4999
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 498

Re: Can't pronterface to board

Postby 3DSheffield » 2013-May-Sat-13-May

yes i installed the serial driver as administrator also correct COM port selected in pronterface and correct baud rate.

On a win 7 laptop I get the following in the pronterface .exe console. Com 5 is the port listed in device manager. Says device is abstract class control and fuctioning correctly I get one constant green LED on the printrboard (bought from a 3rd party fleabay seller in denmark)

Exception AttributeError: "'NoneType' object has no attribute 'stdout'" in <bound method Tee.__del__ of <__main__.Tee object at 0x03922FD0>> ignored
Traceback (most recent call last):
File "pronterface.py", line 1566, in connect
File "printcore.pyc", line 76, in connect
File "serial\serialwin32.pyc", line 30, in __init__
File "serial\serialutil.pyc", line 260, in __init__
File "serial\serialwin32.pyc", line 56, in open
serial.serialutil.SerialException: could not open port COM5: [Error 5] Access is denied.

Anything obvious?
Many thanks
Dave
  • 0

3DSheffield
Waiting to connect to printer...
 
Posts: 6
Joined: 2013-Jan-Thu-16-Jan
Reputation: 0

Re: Can't pronterface to board

Postby JoeKneale » 2013-Oct-Sat-08-Oct

The tip about looking up the COM# in the device manager saved my day. For whatever reason mine was on COM5, I couldnt understand why Repetier couldn't connect -- this solved it!

Thanks you!
  • 0

JoeKneale
Waiting to connect to printer...
 
Posts: 7
Joined: 2013-Oct-Sat-08-Oct
Reputation: 0


Return to Newbie talk

Who is online

Users browsing this forum: No registered users and 0 guests

cron