arduino cant upload script

Talk generally about other printers

arduino cant upload script

Postby romeo2die » 2015-Mar-Tue-10-Mar

First of all my printer description:
1) Reprap Melzi 2.0: Processor: ATMEGA1284P (Sanguino compatible)
2) Repetier Host with Slic3r
3) Firmware EEPROM

I have been using my printer to print out stuff, using baud rate setting of 115200, THE PROBLEM STARTED when I tried different BAUD RATE setting in FIRMWARE EEPROM configuration to 230400....whenever I tried to connect the printer:
- it connects only for 2-3 seconds then disconnected by itself
- I have changed the baud rate in both my FT232 USB to 230400 and repetier printer setting to 230400 as well....the previous problem still happened

Then I decided to use ARDUINO, have succesfully connected my printer with the software, downloaded all the necessary configuration change from the repetier website (cant post URL here)
but when I tried to upload the file:

"Third-party platform.txt does not define compiler.path. Please report this to the third-party hardware maintainer.
Error while uploading: missing 'recipe.cpp.o.pattern' configuration parameter"

Can anyone please help me solve this? ive been struggling with this thing for a looooong time


Regards
  • 0

romeo2die
Waiting to connect to printer...
 
Posts: 2
Joined: 2015-Mar-Tue-10-Mar
Reputation: 0

arduino cant upload script

Sponsor

Sponsor
 

Re: arduino cant upload script

Postby romeo2die » 2015-Mar-Wed-09-Mar

can someone help me please? =(
  • 0

romeo2die
Waiting to connect to printer...
 
Posts: 2
Joined: 2015-Mar-Tue-10-Mar
Reputation: 0

Re: arduino cant upload script

Postby PxT » 2015-Mar-Wed-09-Mar

This forum is primarily dedicated to the Printrbot brand of printers. Looks like you are using a different type. You may have better luck posting in the reprap.org forum
  • 0

User avatar
PxT
Print complete...
 
Posts: 1340
Joined: 2011-Dec-Mon-16-Dec
Location: Sacramento, CA
Reputation: 97

Re: arduino cant upload script

Postby Mooselake » 2015-Mar-Wed-15-Mar

The Melzi's ATMEGA1284P has a UART and requires a separate USB to serial chip onboard, so speed matters. Printrbot's use Printrboards, which have a real USB interface without the FTDI USB to serial, and the serial port speed is irrelevant since it always runs at USB bus speed.

While we can sometimes help users of 3D printers, this question is outside our usual expertise. I couldn't find a forum dedicated to Melzi users, but you might check the one for the Mendel90 which uses a Melzi. Otherwise I suggest Dr. Google. Have you considered the easy approach, just go back to 115,200? Not a lot of advantage, unless you're printing a lot of very short line segments, to the higher speed.

Sorry.

Kirk
  • 0

Modified KickStarter Classic Plus 7/2012
KS Thingybot Delta Pro 10/31/16
User avatar
Mooselake
My next printer is...
 
Posts: 3565
Joined: 2011-Dec-Tue-23-Dec
Location: Moose Swamp, Upper Michigan, USA
Reputation: 171


Return to General

Who is online

Users browsing this forum: No registered users and 1 guest