End stops not working with G2 Board

Talk about modifications to the printer

End stops not working with G2 Board

Postby Old Man Printing » 2018-Mar-Sat-11-Mar

So I installed the G2 board on my metal plus using octoprint with limited success. When I start octoprint I can use the manual jog buttons to move in x, y and z directions.
The hot end heats up and I can manually extrude material. So far so good right? Well here is what I can't do. I can't hit the home button because it does not stop moving causing the drive sprocket to grind up the belt. I tried flashing the firmware but the flip program said I am missing the usb driver. (Tried in win 7 and 10) I have no clue how to make octoprint recognize the the end stops. I did test them and mechanically they work fine. Last and at this point a minor problem is the bed does not heat. I say it is minor because if I can't home the print I can't print so aside from making a toasted cheese sandwich on it the heated bed is of no use. Any help or directions would be great. Thanks,
  • 0

Old Man Printing
Waiting to connect to printer...
Posts: 3
Joined: 2018-Mar-Sat-09-Mar
Reputation: 0

End stops not working with G2 Board



Re: End stops not working with G2 Board

Postby Mooselake » 2018-Mar-Fri-17-Mar

G2 conversions on older printers are still pretty rare, but it sounds like you don't have the home switches on the right pins and/or that you need some magic JSON incantation to get them recognized. For now I'd avoid Octoprint (why introduce another variable) and print directly from your PC until you get it sorted out. From Brook's recent comments you'll need to feed the board some commands in the JSON language (a relatively new and still uncommon replacement for gcode. as in gcode has worked successful since the 70s or so, so lets replace it) to adjust the digipots controlling the motor currents before you start printing, and this might be difficult to do from Octopi.

You can't use flip since it's not an AVR processor. Printrbot's support site (we're an unofficial site dating back to the times when Printrbot didn't have any support) should have directions and links to download the proper tools. The last time I checked you could only flash the G2 firmware from a Mac (Printrbot's in-house programmer is a Mac fanbois, or is that fanboi), in the past non-Maccers needed to send the board back to PB. Hopefully you can avoid reflashing (despite urban legends it's rarely necessary, and is a late step in the problem solving process, and if you're having a config issue that requires recompiling it won't make any difference), or if you get to that point they might have started supplying Windoze based tools. After all, Windows is probably 90% of their customers, with the rest split between Linux and MacOS

Brook was posting here recently, perhaps he'll swing back by and comment. See if you can find his recent posts for ideas. I seem to recall that getting the bed going was tricky, but it can be done.

  • 0

Modified KickStarter Classic Plus 7/2012
KS Thingybot Delta Pro 10/31/16
Creality Ender 3 Pro 12/2019
User avatar
My next printer is...
Posts: 3625
Joined: 2011-Dec-Tue-23-Dec
Location: Moose Swamp, Upper Michigan, USA
Reputation: 177

Return to Mod talk

Who is online

Users browsing this forum: No registered users and 1 guest