Z-Axis randomly goes to maximum during print

Troubleshooting talk for software

Z-Axis randomly goes to maximum during print

Postby superali77777 » 2015-May-Tue-02-May

Hi,

I have some issues with my Printrbot Simple's (Kit, 2013) z-axis.
While printing, it will suddenly move all the way up, even beyond the usual printing area.
Then it does the same thing in reverse, so the z-axis moves back down. Now it moves way farther than the first time, though.
Consequently, it presses against the printing board (and the so-far print), causing the y-axis to bend a little.
Eventually, it will then try to continue the print, which is hopeless, since the print is already messed up and the tension on the z-axis is way too big.

I've had this issue from the beginning on. After reflashing the firmware (Rev. D Board) the problem seemed to be solved and it worked reliably for more than a year.
Lately though, it started doing this strange motion again, so all my prints would mess up sooner or later.
I reflashed the firmware one more time but it still does that.
Maybe you've had similar issues or have an idea about how to solve this issue.

Thank you so much!
  • 0

superali77777
Waiting to connect to printer...
 
Posts: 3
Joined: 2014-Jan-Thu-16-Jan
Reputation: 0

Z-Axis randomly goes to maximum during print

Sponsor

Sponsor
 

Re: Z-Axis randomly goes to maximum during print

Postby RetireeJay » 2015-May-Tue-09-May

Stepper motors only move when they receive steps from their controller. Unlike DC motors, which can move continuously when connected simply to a battery, steppers require a very specific sequence of plus and minus currents through their two coils.

So what this means is that the stepper controller chip for the Z motor on your board thinks it's receiving a sequence of step commands from the CPU. In fact, it probably is - but there's a small probability that there's a bad connection between the CPU chip and the stepper controller chip, or a defect inside your stepper controller chip. Or maybe a stray wire is touching the board, or there's an unintended connection between two traces on the board that are intended to be separate.

The fact that once you solved this problem by re-flashing the firmware suggests that it's a firmware problem, not a hardware problem. But maybe if it is in the category of a stray wire or a nearly-invisible short between traces on the board, then maybe the physical act of installing the programming jumper and then removing it, and pressing the reset button disturbed the physical defect enough to make it "go away" for a while. You might try just pressing your finger on the board at different places while it's misbehaving to see if the problem is electro-mechanical.
  • 1

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
"My next printer is..." Prusa i3 MK3
User avatar
RetireeJay
My next printer is...
 
Posts: 4991
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 498


Return to Troubleshooting talk

Who is online

Users browsing this forum: No registered users and 1 guest

cron