Page 1 of 1

When is a Board Reflash Necessary (USB Troubleshooting)

PostPosted: 2018-May-Tue-19-May
by IPrintThereforeIAm
Hello all.

I ran into a bit of a snafu with my Printrbot after the latest update for Windows 10. Initially, my printer was able to connect to Repetier 2.0.5, and I was doing some manual extrusion to switch filaments. Unfortunately, the connection ended mid-extrusion, and I started having trouble re-establishing the connection. I updated Repetier to 2.1.0, re-installed the teensy driver (http://pjrc.com/teensy/serial_install.exe), cycled power, etc. But here is what fixed the issue: In the "Devices and Printers" section of the control panel, I right clicked and hit "Remove Device" for the Printrbot. Then, I cycled the power for everything, and was able to connect through Repetier. The Printrbot was automatically added to "Devices and Printers". This was last night, and I decided I would start printing today.

Unfortunately, life is not so easy. I ran into the same issue today, so I hit "Remove Device" in the control panel and installed the teensy driver yet again. This time, no luck. I also tried the VCP (Virtual Com Port) driver wizard suggested by Printrbot (https://printrbot.zendesk.com/hc/en-us/articles/204376564-Troubleshooting-USB-Connection). This time, I can't even get the printer to show up under "Devices and Printers" in the control panel. I checked if the green light on the board was on (it was), and tried to connect to a different computer as well (Windows 7 OS, didn't work).

I have a tendency to shoot first and ask questions later, so I figured I would try to get a second opinion before I gave my printrboard a Reflash. Am I missing something, or is it time to bring out the heavy artillery?

Also, if I do have to Reflash, how do I start if I can't even connect to the computer?

Here is what I am running:
Printrbot Simple Metal, Rev F6 board, heated print bed added
RepetierHost 2.1.0
Windows 10
MicroUSB connection via USB 2.0 port

Re: When is a Board Reflash Necessary (USB Troubleshooting)

PostPosted: 2018-May-Wed-05-May
by RetireeJay
Well, the only clue in your description that really points to the Printrboard is when you tried a Win-7 computer and it didn't work. Is that a computer that you know has worked in the past? If so, then perhaps it's legitimate to think that something has changed on the Printrboard. Otherwise, you have so many unknowns floating around that it's impossible to pin down the Printrboard as the culprit. In fact, the most recent change before the problem was with the W-10 upgrade.

The way the Printrboard is set up, there is zero chance that the change of computer OS to Win-10 could, by itself, corrupt the firmware on the Printrboard. To do that, you would have had to go into programming mode with the jumper and reset switch on the board.

You might try getting an SD card and printing from that as a troubleshooting measure.

Re: When is a Board Reflash Necessary (USB Troubleshooting)

PostPosted: 2018-May-Wed-15-May
by ktfergus
Don't even get me started on Windows 10 "updates", but before I go on a rant about "homegroups" disappearing, I suggest you swap out usb cables just to eliminate that possibility.

-Kelly

Re: When is a Board Reflash Necessary (USB Troubleshooting)

PostPosted: 2018-Jun-Sat-07-Jun
by IPrintThereforeIAm
Okay, I had time to try a few more things, and here are my observations:

Tried new USB cable, with no success
Tried a spare Rev. f6 printrboard, with no success
Tried printing with a 2gb. micro SD card, with no success

My theory is that, on both my Windows 7 and Windows 10 machines, the teensy driver and the VCP are either incompatible with each other, or one or both are installed/configured incorrectly. Will try removing them and playing around with installing them again.

Also, no idea why print from SD is not working.