Page 1 of 1

Stepper Motor Replacement

PostPosted: 2018-Nov-Thu-14-Nov
by hstemerson
Hello. I need to replace the stepper motor that controls the filament feed. I've googled it about 100 different ways, and can't seem to get any real information about what it is. Anyone know what I need (specifically) as a replacement? I've even googled the serial code stamped into the motor, and that seemed to take me to steppers that weren't a good fit. Again, any help you can give would be great. Thanks.

Re: Stepper Motor Replacement

PostPosted: 2018-Nov-Fri-10-Nov
by RetireeJay
I'm going to answer you in two parts. Part 1 is why you probably don't need a new stepper, and Part 2 is how to get a new one if you really do need it.
Part 1
Stepper motors are extremely simple inside, and they very rarely fail They have two coils of copper wire, and some steel. Each end of the motor has bearings (which can fail, but rarely in our use). There are no brushes for electrical contact; there are no gears.

If you remove the stepper motor from the extruder, does it turn normally? If it does, then the problem is probably a jammed extruder.

If the motor does not turn normally, then the problem is probably a broken wire. Insulated wires can break internally while looking just fine externally. The most likely cause of internal breaking is "fatigue failure" which happens at any point where the wire is repeatedly bent back and forth at a single point. This has happened to me. I replaced the wires and then installed "cable chain" to manage the flexing of the wires and prevent single-point flexing.

It's possible for the chip on the board to fail. It can be helpful for troubleshooting purposes to swap connections, e.g. plug the extruder motor into the X-axis and the X axis into the Extruder connector on the board - just to verify that the problem moves with the motor or stays with the connector on the board.


Part 2
It shouldn't be hard to find a stepper motor; there are hundreds on the market. The one on my Printrbot Plus extruder is a Kysan 1124090.

The steppers used on Printrbots (and basically all other consumer 3D printers) are "NEMA 17" which refers to the size of the "face" of the motor and the spacing of the mounting bolts. Within that broad category, there are motors with more or less "depth", which is roughly going to correspond to the available torque. Then, once you have decided on a NEMA 17, 200 steps per revolution motor that is, for example, 19mm deep, then you will find that there are motors with different ratings for current, voltage, and "holding torque". The motor control chips on Printrboards can source over 1 Amp, so choose a motor that has a current rating near an amp and a voltage as far below 12V as you can find (the voltage rating isn't very useful; it's the current that matters, but higher voltages tend to mean the motor will run hotter)

The one thing you will probably NOT be able to find is a motor that's pre-wired with a cable just the right length and terminated in the right kind of connector. So plan to take the cable from your old stepper motor, cut the cable, and splice the wires from your new stepper onto the old connector.

Re: Stepper Motor Replacement

PostPosted: 2018-Nov-Mon-12-Nov
by hstemerson
Thanks so much RetireeJay. We tested the stepper motor by plugging it in as the y-axis stepper motor, and it ran perfectly. Good call. We're looking now at your additional recommendations.

We had already tried it off the machine and we were pretty certain it wasn't a jam. It's running like a 1/4 (maybe less didn't really measure the rotation) turn forward and then backwards . . . in an oscillating fashion.

Re: Stepper Motor Replacement

PostPosted: 2018-Nov-Thu-08-Nov
by hstemerson
So we put a volt meter on the wires and got some strange readings. It looks at least like the wires are good. What's our next step? I've got a video, but I can't upload an mp4 and I can't send a link. I guess I'll try it like someone who has no clue what to do. There is a link in the attached document to the video . . . Again, any advice would be greatly appreciated.

Re: Stepper Motor Replacement

PostPosted: 2018-Nov-Thu-10-Nov
by RetireeJay
Strange readings on the motor leads would actually be normal. The current being sent to the motor is "chopped" and will have a significant AC component, even when the motor is stationary. And the average voltage sent to each coil will depend on exactly what "microstep" the controller has settled on. If the motor is supposed to be moving, the voltages on each coil will get even more confusing; you would need a 2-channel oscilloscope and the complete datasheet for the controller chip to make sense of them. The only thing you could learn with an ordinary voltmeter is if one of the coils is open-circuit (voltage on one coil always much higher than the other, i.e. close to 12V vs close to 2 or 3V) or if the driver circuit is not sending any current (voltage on one coil is always zero).

Your video could be symptomatic of a mechanical "stop" that prevents the shaft from turning, or it could be a result of somehow one of the coils is not getting current at all.

If this motor turns normally when you plug it into the Y axis channel on the board, that proves that the motor and its wires are OK. Therefore, the resulting problem is almost certainly on the board. If I were you, I'd prove that by plugging a different motor into the Extruder channel and observing a failure to rotate.

Once you prove that the problem is on the board, there are several components that can be examined. If you have someone who knows how to do electronics repair, here's the schematic of the motor control. I would focus on the connector (JP5), the controller chip itself, and the resistors R30 and R31 - first to make sure that all the solder connections are intact, then to make sure the resistors are not broken or burned out.
PrintrboardExtruderStepper.JPG

Re: Stepper Motor Replacement

PostPosted: 2019-Feb-Sat-13-Feb
by hstemerson
So it's been a while since I've posted here, but I wanted to post an update and see if I could get any feedback (I'd love to hear from you RetireeJay). We had the same error with different stepper motors plugged in, and success with the extruder stepper plugged into the Y motor. Since then we've been busy, but we grabbed a replacement board, hooked everything up and got the same error with the stepper motor. Tested another motor and got the same error again. I'm assuming at this point we're talking about software/drivers. Any thoughts, please let me know. Thanks so much.

Re: Stepper Motor Replacement

PostPosted: 2019-Feb-Sat-16-Feb
by RetireeJay
I'm not quite sure I understand your last post correctly.

I think you are saying that
(1) The Extruder motor ran fine when you plugged it into the Y motor port on the card.
(2) And other motors misbehaved when plugged into the Extruder port on the card.

So far, so good - sounds like a hardware problem on the card.

But then you say that you got a replacement card and saw exactly the same symptoms with the new card.

This seems impossible. Even if the problem on the old card was with software rather than hardware (which is EXTREMELY, EXTREMELY unlikely), the new card would have good software on it. (Are you sure you didn't get disoriented and test the old card twice instead of testing the new card?)

Or am I mis-understanding your explanation of your tests?

Is there anything at all "in common" between the two setups? Normally, Marlin software won't allow you to move the extruder motor at all unless the hot end is heated up to temperature. So are you using the same power supply with both boards and for all tests? Maybe the power supply is not handling the load of the hot end heater very well, and the undervoltage coming from the power supply is making the Extruder motor freak out. If that's the case, then I would think that X, Y, and Z would also freak out when the Hot End is being heated.

Re: Stepper Motor Replacement

PostPosted: 2019-Feb-Wed-10-Feb
by hstemerson
You've read my previous post perfectly. You had told us to check the board, and we lack some of the tools to actually work with the board. We ordered a new printrboard, hooked it up, and got the exact same error. I was assuming that the error would be from the computer sending the code over, I think you were talking about the board level software. We're using repetier to run the printer through the USB connection. I'm really at a loss at this point. We'll look at the power supply. Thanks.