Massive Motherboard Problem

Need help troubleshooting hardware issues... talk here

Massive Motherboard Problem

Postby Tsunotech » 2013-Sep-Thu-18-Sep

hello, first time here so please excise any errors on my part. so i have a printrbot plus model, and everything was working fine until about a month ago the main power connection on the motherboard started shorting and melted to the casing. this caused random emergency shutdowns among other obvious short problems. anyway i re-installed a new cable and plug but while testing it out i momentarily inverted the power(13-13.5v) and now when powering up it will not be recognized by the computer. i fear i may have destroyed some of the motherboards hardware. any help would be appreciated thank you.
  • 0

Tsunotech
Waiting to connect to printer...
 
Posts: 4
Joined: 2013-Sep-Thu-18-Sep
Reputation: 0

Massive Motherboard Problem

Sponsor

Sponsor
 

Re: Massive Motherboard Problem

Postby Tdeagan » 2013-Sep-Fri-14-Sep

Ouch! There aren't a lot of things to check. You've tried a different USB cable, so next try a different USB port on the computer. Lastly try a different computer. If you can't get any love from either of these, you may be looking at a fried board.

On the outside chance you've got a AVR programmer of some sort you could attempt to talk to the board through the ICSP port, but that's only going to tell you if the chip is responding.

Good luck!
  • 0

Tim Deagan
KC5QFG
(optional Dual Extrusion) Printrbot Plus V1 [3/2013]
bed stabilizers, bed levelers, Y & X belt tensioners,
50mm fan mount, LED ring light, Z-axis screw Isolators,
Z-shaft stabilizers,optional Bowden conversion, GT2 belts/pulleys,
M8x1.25 Z Screws, Flex. Z-couplers,
RAMPS 1.4 w/ LCD,
Quick Change Extruders:
Option 1- Dual hybrid geared Wade's/Bowden w/ 3mm & 1.75mm Ubis,
Option 2 - Dual direct geared Wade's w/ 3mm & 1.75mm Ubis
Option 3 - Single geared Wade's w/ 3mm or 1.75mm Ubis
Option 4 - Single belt drive Wade's w/ E3D
MIC-6 metal bed
Thingiverse Profile: http://www.thingiverse.com/tdeagan/designs
User avatar
Tdeagan
Waiting for printbed temp...
 
Posts: 149
Joined: 2013-Feb-Fri-14-Feb
Location: Austin, TX
Reputation: 11

Re: Massive Motherboard Problem

Postby Tsunotech » 2013-Sep-Fri-17-Sep

yeah i tried all of that, was wondering though could the chips/capacitors be replaced ??, i mean a new board is like $125.00
  • 0

Tsunotech
Waiting to connect to printer...
 
Posts: 4
Joined: 2013-Sep-Thu-18-Sep
Reputation: 0

Re: Massive Motherboard Problem

Postby mdfast1 » 2013-Sep-Fri-18-Sep

Yes all the parts can be replaced, but is it worth it for you to diagnose and find which component is bad is your call. The printrboard BOM and schematics are here to help with troubleshooting + part ordering: https://github.com/Printrbot/printrboard
  • 0

Printrbot Simple Metal - RED -
UBIS 13

Printrbot LC+ - Operational

Printrbot Original- Donated
GT2 - 20 Tooth Pulleys
GT2 Belts
Brass Threaded Rods
Spur Gears from drawcut
.35mm nozzle
User avatar
mdfast1
Layer 650 of 1234
 
Posts: 667
Joined: 2012-Feb-Thu-12-Feb
Reputation: 12


Return to Troubleshooting talk

Who is online

Users browsing this forum: Google [Bot] and 1 guest