Page 1 of 1

Printrbot connects to pc but will only goto home position

PostPosted: 2013-Jun-Sun-13-Jun
by jdaggie13
I recently assembled a Printrbot Jr. and was able to connect to Repetier, and when I tried to manually control the bot it gave me the error, Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting).

But when I send the bot home it will return home so I know the axes motors are working.

I tried Pronterface and had the same problems.

Also the extruder won't heat up or read temperatures.

And where can I buy a cable to connect my fan to the board?

Thanks in advance

PostPosted: 2013-Jun-Sun-19-Jun
by Mooselake
In Repetier-host you should be able to check the log (drag the top of the logging area up if it's not visible.) For displayed errors.

You should be able to find a fan extension cable at many computer stores; I got one from Amazon. A 2 wire cable is best, but a 3 site will work fine - just let the extra pin hang off the side, and make sure you use the same two sides on both ends.

Kirk

Re: Printrbot connects to pc but will only goto home positio

PostPosted: 2013-Aug-Sat-17-Aug
by Tdeagan
Have you gotten anywhere with this? After upgrading my firmware on my Rev D. Printrbot Plus V1, I get the same behavior if I attach the Extrudrboard. It will home the axis, but anything else results in:
Code: Select all
Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
>>>m999
SENDING:M999
Resend: 1
Error:2
: Extruder switched off. MINTEMP triggered !
Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)


There is nothing in the pronterface.exe.log, here's Repetier-Hosts log output:
Code: Select all
17:15:44.727 : Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)


If I inject M999 I get:
Code: Select all
17:16:13.817 : Resend: 1
17:16:13.836 : Error:2
17:16:13.836 : : Extruder switched off. MINTEMP triggered !
17:16:13.836 : Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)


If I attach the LCD, the com port disappears and I can't talk to the printer.

Re: Printrbot connects to pc but will only goto home positio

PostPosted: 2013-Sep-Sun-13-Sep
by Tdeagan
Though I'm not exactly sure which part fixed this, I got it working and talked about the details in this thread:http://www.printrbottalk.com/forum/viewtopic.php?f=15&t=4891