Page 1 of 1

Board not responding after flashing bootloader via ICSP

PostPosted: 2018-Jul-Wed-03-Jul
by __Vinz__
Hi there,

In the process of installing the LED strip on my Rev F5 printrboard on my Play, I tried upgrading the firmware to have such support in Marlin.

Unfortunately, using dfu-programmer did not work: the 'erase' command would complete without errors but the flashing step would error out with the infamous 'image did not validate' (see attached file for errors, you can also see that when debugging is enabled, the erase step seems to actually fail with errCHECK_ERASED).

Looking at the forum threads, it looks like this is because the lock bits are set in the chip, preventing the firmware to be erased. I then proceeded to use the ICSP connector to investigate that. After finding the right pinout, I can successfully talk to the chip (cf attached logs), its signature being recognized.

I then proceeded to backup the chip but strangely, reading the flash did lead to an empty file (is this another lock protection bit preventing firmware dump?).

I tried dumping the lock bit value (using 'avrdude -p AT90USB1286 -c avrisp -b 19200 -P /dev/ttyUSB0 -U lock:r:lock_bit:d') and the resulting file contains a '0' character in it. Does that mean the lock bit is set?

Anyways, it was not clear what whas happening so I proceeded to rewrite the bootloader (cf attached file for command and session) as well as the fuses (I used the values which were already previously set). This seemed to work fine. I used Lincomatic DFU bootloader at, md5sum of the hex is :5e960b7f0aef8ad1f82f089e9735e484 BootloaderDFU.hex

The problem is that now the board does not seem to connect at all to my PC (tested with two PCs) and I am not sure what is the next step here. I verified I still have ICSP access but I fear there might be a hardware problem (dead USB controller?).

Could anyone make a suggestion on what a good next step would be?

Thanks much for the help!

Re: Board not responding after flashing bootloader via ICSP

PostPosted: 2018-Jul-Thu-01-Jul
by __Vinz__
Hi again,

Tonight, I have tried a chip erase using avrdude and reprogrammed the DFU bootloader, without a change (board still does not appear over USB when connected and out of ISP mode). I have also tried to flash the CDC bootloader (both from Lincomatic blog above), again to no success.

Could it be a firmware flash issue (i.e. bad firmware preventing the board from being seen over USB)? I don't know how the board is supposed to behave when no bootloader is present: does it appear on the USB bus or not at all?

If this is a hardware issue, could sb point how I can diagnose whether the USB controller is dead?

Thanks for the guidance!