Page 1 of 1

Y axis moving but not registering

PostPosted: 2018-Jun-Sun-21-Jun
by swedishk
I have an old wooden simple, it's worked well enough for a few years. It worked fine on a ~2 hour print two days ago. Yesterday it lost connection with the computer, and the computer wouldn't recognize it at all. today I flashed the firmware, connected all good, or so I thought. Z and X axes work normally, Y axis will home just fine, the physical endstop works, but if i try to move even 1 step off of zero, it will travel all the way to its physical limit and start skipping teeth on the belt. I've done a fair amount of searching today and haven't found anyone with the same issue. any ideas?

rev F4


Update: it only does this coming off the endstop.

Re: Y axis moving but not registering

PostPosted: 2018-Jun-Mon-08-Jun
by RetireeJay
You may have flashed a wrong version of the firmware. Some Printrbots have the Y endstop at Y = 0 while others have it at Y = Max. And some Printrbots have larger Y axes than others. So if the firmware you flashed thinks Y endstop is at Y Max, and if it thinks that the Y axis is longer than it really is, then when you try to go to Y = 0, it moves away from "Max" toward "zero" but hits the physical limit before it stops.

Your belt should be tight enough that the toothed pulley doesn't slip teeth. The motor will chatter, but ultimately your motor is skipping magnetic "poles" which is entirely harmless to the motor.

Does the motor stop driving beyond the end of travel after a second or two? If so, that would tend to verify my hypothesis - it thinks it has reached the true zero position. (Printrbots don't have any way to sense actual position except the "endstop" switches, so they keep track of position by counting steps delivered to the motor).

Re: Y axis moving but not registering

PostPosted: 2018-Jun-Mon-11-Jun
by swedishk
Ah, I assumed all that noise was from the belt. Good to know.

Y=0 is on the end stop switch. Yes it stops after a couple seconds. What’s really driving me nuts is that any input takes it past the end.

Re: Y axis moving but not registering

PostPosted: 2018-Jun-Mon-19-Jun
by RetireeJay
What does your User Interface say the value of Y is when it has just finished "homing"?

Re: Y axis moving but not registering

PostPosted: 2018-Jun-Mon-21-Jun
by swedishk
Y home = 0

when make any input to come off of 0, it runs to the end and skips poles, still showing zero. if i try to move it from the new "zero" it behaves normally and responds to manual inputs normally. if i try to home it from here, it goes back to the physical endstop switch and reads 0.

update: g28 puts the head a little over halfway to the right and around 3/4 of the way to the front.

updatev2: the m211 values were way over what the physical bed size is. changed those back to default settings. i don't think this is the most permanent solution, but it's got me printing again and not pulling my hair out. it's a small win and i'll take it.