Page 1 of 1

Teensy says flash limit is 64K Simple Metal

PostPosted: 2018-Apr-Sun-14-Apr
by LarsR
I am having some trouble with my Printrbot simple metal with the F7 board. It stopped being able to connect with Cura or with Repetier. So I power cycled everything, tried different cables, etc to no avail. As a last resort, I tried to reflash the board using the Arduino IDE and the same firmware that I had used previously when I installed my E3D V6 extruder. The Arduino IDE said everything looked fine, but that Teensy did not respond to a request to enter program mode. I looked at the Teensy log, and it said that I didn't have enough memory, as follows:

12:01:57.339: remote cmd: "file:Marlin.ino.hex"
12:01:57.355: File "Marlin.ino.hex". 82006 bytes, 127% used
12:01:57.371: File contains data beyond chip size, yikes!

Does this mean that my Atmel chip Flash has failed somehow? Or is there something else going on? I also tried to do a local print with an SD card, and no response, and I tried to download with Atmel Flip and go the message "Could not read from USB device". Any advice would be helpful before I get a new board.

Re: Teensy says flash limit is 64K Simple Metal

PostPosted: 2018-Apr-Sun-17-Apr
by RetireeJay
On a Windows computer, you use FLIP to upload the hex file to the Atmel chip. The standard uploader within the Arduino IDE can't handle the file size.

Your message implies that the uploader thinks your Atmel chip has 64K of memory, but in fact it has 128K. Are you sure you have chosen the correct target type for your upload? There should be a 128 somewhere in the name.