Having to re-flash firmware everyday

Need help troubleshooting hardware issues... talk here

Having to re-flash firmware everyday

Postby printrbotPete » 2016-Dec-Sun-22-Dec

Hello,

I have a Printrbot simple metal 1403 with x axis extension (installed 6 months ago) and heated bed (1 week ago). I am using a printrboard rev F6, which was also installed a week ago with a new power supply to handle the heated bed's current requirements. After installing, I flashed the 8/10/2016 firmware update. I forgot the M502 command initially. This resulted in the y-axis running just a few mm at a time in the wrong direction when the y-home button was pressed. Everything else worked fine.Once I figure out my mistake, I re-flashed the firmware, and sent the M502 command. Everything worked, and I ran a 6 hour print with no incident.

The following day, I went to print and the same behavior was back. Y axis moves a few mm in the wrong direction when homed. I tried the M502 reset to no effect. The behavior continued. I flashed the firmware again and the problem was again resolved.

Today, I have the same problem. What the heck? Anyone have any experience with similar symptoms? Any ideas where to start troubleshooting this kind of problem? Any help would be appreciated :)
  • 0

printrbotPete
Waiting to connect to printer...
 
Posts: 1
Joined: 2016-Nov-Wed-08-Nov
Reputation: 0

Having to re-flash firmware everyday

Sponsor

Sponsor
 

Re: Having to re-flash firmware everyday

Postby Mooselake » 2016-Dec-Sun-22-Dec

I suspect you cycled power between the two days.

When you turn your Printrbot on the firmware will load some parameters that were stored in EEPROM into RAM. From your description yours are wrong. M502 will load default values for those parameters into RAM, overwriting the saved values. Those must be working for you. As soon as you turned off the power those default values were lost, and then replaced by whatever had been saved in EEPROM when you powered back up. To reset the saved values to the defaults do an M502 followed by an M500. M500 replaces the EEPROM values with the current ones.

All that reflashing is not helping, since it does not reset the EEPROM values if you're reflashing the same firmware (different versions sometimes will add or remove firmware items or order they're saved in, and there's a mechanism to trigger an EEPROM wipe, but that doesn't apply here). Despite the urban legend of flash first, flash often you're taking a chance that you'll brick your board. Like many legends it's bad advice. There are legitimate reasons to reflash - new firmware, replacing the rare case of damaged firmware, but for general debugging reflashing should be close to the last thing on your list.

Try M502/M500, cycle power (with the usual 20 seconds or so off time), then see if the problem is resolved. Let us know.

Good Luck!

Kirk
  • 1

Modified KickStarter Classic Plus 7/2012
KS Thingybot Delta Pro 10/31/16
User avatar
Mooselake
My next printer is...
 
Posts: 3352
Joined: 2011-Dec-Tue-23-Dec
Location: Moose Swamp, Upper Michigan, USA
Reputation: 165


Return to Troubleshooting talk

Who is online

Users browsing this forum: No registered users and 3 guests

cron