Provided Auto-Level Spacer always sets Z-axis to high

Need help troubleshooting hardware issues... talk here

Provided Auto-Level Spacer always sets Z-axis to high

Postby DeadCthulhuWaits » 2019-May-Sun-12-May

Hey All,
I've had my Printrbot Simple Maker(1405) for a few years now and have had the same problem from the start. The 2mm spacer provided for setting the Z-axis has never worked for me, I was wondering if anyone else has run into this problem? My printer seems to work best with a gap of around 1.7mm. I have been setting my z-axis by zeroing the z as instructed but, rather then using the spacer I have been forced to manually set the auto-leveler by hand. Basically I loosen it up and set it to the depth where the red light just comes on, this seems to be it's intended function unless I'm mistaken. I might accuse my sensor of being faulty but I had to get a new board a year or two after getting my printer and with the new board they had also sent me a brand new auto-level sensor, which made no difference when shimming the z-axis.

Another issue with the auto-leveler I'm not understanding is why it zeros fine at the home position of the y-axis but when extended out during the auto-level process the nozzle hits the bed. Now I would assume that when it hits the bed it would force the z to lift towards the front and move lower towards the back unless I'm mistaken, but it seems to do the exact opposite moving tighter where it's closer and further where there is a greater gap. Something I notice in Repetier-Host makes me wonder if it reads the y-axis backwards somehow. The reason I suspect this is from the y-axis' home position I can not move the head out by using positive values when jogging the y, it only moves forward using negative values, which in turn requires me to trick the program by first using a max positive value and then and only then will I be able to move the head out using negative values. Is this normal? If not any advice on fixing it would be greatly appreciated.
  • 0

DeadCthulhuWaits
Waiting to connect to printer...
 
Posts: 7
Joined: 2019-May-Sat-12-May
Reputation: 0

Provided Auto-Level Spacer always sets Z-axis to high

Sponsor

Sponsor
 

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby MartyS » 2019-May-Sun-16-May

Are you dialing in M212 every time you move the hot end or Z probe?

When the light goes on the nozzle should be about a millimeter away from the bed.

The proper procedure is to set the Z probe manually using the spacer, then set M212 Z to a small enough value so the nozzle doesn't hit the bed, then do test runs making M212 Z larger and larger until you get a proper first layer squish.

The probe should detect the bed between 3 and 4 mm away, If you are using a thick pad on your bed you may have to set the probe lower than 2mm so you can set M212 properly.

Edit: M212 Z is negative, so by larger and larger I mean more negative, example -0.4 to -0.8
  • 0

Last edited by MartyS on 2019-May-Sun-16-May, edited 1 time in total.
MartyS
Honeycomb infill 25%...
 
Posts: 260
Joined: 2014-Jul-Wed-10-Jul
Reputation: 8

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby DeadCthulhuWaits » 2019-May-Sun-16-May

Hmm, not sure what instructions I was using anymore but there was nothing about setting M212, do you by any chance have a link to where I might get "Good" instructions?
  • 0

DeadCthulhuWaits
Waiting to connect to printer...
 
Posts: 7
Joined: 2019-May-Sat-12-May
Reputation: 0

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby MartyS » 2019-May-Sun-16-May

DeadCthulhuWaits wrote:Hmm, not sure what instructions I was using anymore but there was nothing about setting M212, do you by any chance have a link to where I might get "Good" instructions?



Brook's video is still up on Youtube:

https://www.youtube.com/watch?v=jpmgI4OGldw

Same instructions for the wood maker as the simple metal shown in the video.
  • 0

MartyS
Honeycomb infill 25%...
 
Posts: 260
Joined: 2014-Jul-Wed-10-Jul
Reputation: 8

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby DeadCthulhuWaits » 2019-May-Sun-20-May

Ok, thank you very much I'll take a look.
  • 0

DeadCthulhuWaits
Waiting to connect to printer...
 
Posts: 7
Joined: 2019-May-Sat-12-May
Reputation: 0

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby DeadCthulhuWaits » 2019-May-Sun-21-May

That makes a lot more sense now. Unfortunately it has led me to a new problem, M212 does not change, it always remains at Z0.00. I've tried capital letters, positive values, adding in the x and y, still nothing.
  • 0

DeadCthulhuWaits
Waiting to connect to printer...
 
Posts: 7
Joined: 2019-May-Sat-12-May
Reputation: 0

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby DeadCthulhuWaits » 2019-May-Mon-00-May

Updated Repetier-Host from version 1.0.6 to the latest and greatest, still can't get the M212 command to register for some reason but, they did add a setting for it in the printer settings, so I'm finally dialing it in correctly. Thanks for your help.
  • 0

DeadCthulhuWaits
Waiting to connect to printer...
 
Posts: 7
Joined: 2019-May-Sat-12-May
Reputation: 0

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby RetireeJay » 2019-May-Mon-06-May

Regarding the Y axis, some versions of Printrbot "home" to Y = 0; other versions "home" to Y = YMAX. Using Repetier you can easily tell if you click the "home" icon for Y and observe the value it shows for Y after homing.
Also, see this post viewtopic.php?f=16&t=3484 to confirm if your printer is correctly calling Y = 0 in the correct position. No matter which version of Printrbot you have, Y = 0 should end up in the same place (even if "home" is not at zero). If it doesn't then maybe you have the wrong firmware loaded.
  • 0

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
"My next printer is..." Prusa i3 MK3, upgraded to MK3S
User avatar
RetireeJay
My next printer is...
 
Posts: 4996
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 498

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby DeadCthulhuWaits » 2019-May-Mon-17-May

It's beginning to look like firmware is the all encompassing problem. I posted the issue with M212 not taking on Repetier's forums and am being told that not all printer firmware will accept the command. How would I go about updating/changing the firmware to a better version? Board on my printer is a Rev. F4, is it possible to put the repetier firmware onto that board maybe? I have never changed the firmware before so as far as I know it is the stock firmware that came on the board.

From what I'm seeing the printer will not allow a Z value in the negative range, no matter what the value I use in the Z offset in Printer Settings, 0 is as low as the z value reads. So basically, if I have a first layer height of 0.2mm the most I'm allowed to offset the z-axis by is -0.2mm, anything lower doesn't work, once z-axis is at zero it will go no further down.

This leads me to my next issue. Why was I given a shim that requires use of a z-offset when the printer I was sold does not allow offsetting the z? I assume that's why the instructions I was originally given did not include setting M212. So how did they expect this to be done? Not holding anyone to an answer on that, just voicing my curiosity.
  • 0

DeadCthulhuWaits
Waiting to connect to printer...
 
Posts: 7
Joined: 2019-May-Sat-12-May
Reputation: 0

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby MartyS » 2019-May-Mon-19-May

All my boards are rev D, so can't help with Rev F4. I've got one in a simple metal, and one that was a 1405 but is now controlling a large printer I built myself.

If the board has a Printrbot firmware it should accept the M212 commands. Unless it's a really old firmware before they started using the Z probe, I do remember having to flash new firmware when I upgraded from the original wooden printrbot to the 1405 with the probe. But I wouldn't think an F4 board would have firmware that old.

The order you type in the M commands is important, M212 Z-X.X, then M500, then M501 to check if M500 saved correctly. If you run M501 before M500 it can revert back to the previous setting.

I'm guessing the firmware files are still out there but I haven't looked since Printrbot went bankrupt, for the 1405 you would use whatever the latest firmware was for the simple metal.
Flashing is done with a USB cable and a special program running on your computer.
  • 0

MartyS
Honeycomb infill 25%...
 
Posts: 260
Joined: 2014-Jul-Wed-10-Jul
Reputation: 8

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby DeadCthulhuWaits » 2019-May-Mon-20-May

Well I'm an idiot, somewhere along the line I started hitting M501(Restore) to check my settings instead of M503(Report) and kept wiping out the setting. Works great when I don't do that! Thanks again for every ones help.
  • 0

DeadCthulhuWaits
Waiting to connect to printer...
 
Posts: 7
Joined: 2019-May-Sat-12-May
Reputation: 0

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby MartyS » 2019-May-Mon-23-May

Are you doing an M500 every time you change a setting? I got in the habit of doing that from the start in this hobby. Unless things have changed drastically M501 should only recall what was saved with the last M500 command, M503 shows what is in current memory but if it hasn't been saved with M500 any changes made will be lost with the next power cycle or reset.
  • 0

MartyS
Honeycomb infill 25%...
 
Posts: 260
Joined: 2014-Jul-Wed-10-Jul
Reputation: 8

Re: Provided Auto-Level Spacer always sets Z-axis to high

Postby RetireeJay » 2019-May-Tue-12-May

This post tells you how the M500 family of commands work: viewtopic.php?f=18&t=2763

And there's a description of how to flash firmware in the Wiki (red-beige-white box next to the "Search" text box. It's a little out of date, but the principles apply. The wiki includes a link to a site with several different versions of Printrbot firmware.

That said, I always advise making a firmware change only as the absolute last resort, for example if your printer just doesn't work at all. Or if you have bought a new board that was configured for a printer different than the one you have.

You are right about the limits of motion. The firmware won't let you go below zero on any axis. But your probe doesn't necessarily trigger at exactly the right height for the nozzle to lay down the first layer perfectly, so the Offset setting can be negative. However, once the offset is applied, then the printer thinks true Z zero is equal to the probe trigger point plus (algebraically) the Z offset (which is almost always negative).
  • 0

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
"My next printer is..." Prusa i3 MK3, upgraded to MK3S
User avatar
RetireeJay
My next printer is...
 
Posts: 4996
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 498


Return to Troubleshooting talk

Who is online

Users browsing this forum: No registered users and 1 guest