[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4693: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4695: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4696: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4697: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Printrbot Talk Forum • View topic - Simple Firmware Upgrade-M501 doesn't show setting properly
Page 1 of 1

Simple Firmware Upgrade-M501 doesn't show setting properly

PostPosted: 2014-Aug-Fri-11-Aug
by Vapor
So I have been trying to upgrade my firmware on my bot after installing the level probe. I think it's the 1401 model.


Anyhow, when I start it up and check locations m501 shows that they're all at 0.

I job the axis around a bit and try m501 and they're still showing all 0.

I set them to random numbers. I come back and try to check them and they're all showing the exact numbers I changed.

I try to home and X homes, Y crashes into the back instead of moving forward to the end stop switch. Z just goes up a little ways and stops. It's almost like the direction is backwards on it as well.

I've tried about 6 different firmwares that say they should work, but theyr'e all doing the same stuff.

When I home, it moves fast like it should when jogging. When I try to jog an axis, it SLOWLY goes into place.


Have I gone dumb? What am I doing wrong or missing. I've not found any really good information about the firmware upgrade. I think I'm missing something key that I'm overlooking, but I've had it with this thing for now.

Please Help!

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

PostPosted: 2014-Aug-Fri-15-Aug
by RetireeJay
The information at these links may help you to understand what's going on with M500, M501, etc.
viewtopic.php?f=18&t=2763
http://www.printrbottalk.com/wiki/index ... are_Update

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

PostPosted: 2014-Aug-Fri-23-Aug
by Vapor
Thanks, but I know how to go through the process of upgrading the firmware. I'm familiar with gcode as I have a CNC mill.

My main problem is I don't know which version of the firmware may work without reversing my axis.

Along with that, I'm following the commands Brook shows in his probe setup video and my settings don't show what he says they are. Mine stay static, while hid are changing, telling him how to tweak in the probe.

I'm going to try it work as fresh head in the morning, but I still would like to think there is a firmware out there that should work without reversing things, I just don't know how to find it.

Thanks everyone!

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

PostPosted: 2014-Aug-Fri-08-Aug
by Mooselake
When you updated the firmware you lost your saved calibration numbers (I'm assuming all zeros refer to your saved numbers), so you'll need to recalibrate. Hopefully you wrote them down before reflashing.

Depending on your model bot you might need to reverse a motor connector - printrbot's trying to standardize the firmware and eliminate versions for different models. It's a one time thing, and has been discussed several times; try a forum search.

Good luck!
Kirk

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

PostPosted: 2014-Aug-Fri-08-Aug
by Mooselake
What kind of CNC mill? Parallel port or USB controller? Control software?

Kirk

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

PostPosted: 2015-Jul-Thu-10-Jul
by bbrown64
I just flashed my firmware. I have the PB SM 1403. You can find the correct firmware at Scroll down toward the bottom on the right side. You will see a short list of the models of Printrbot. Select the firmware that matches your model. Then Follow the instructions on that same page on how to flash your firmware. It only takes about 10 minutes or less to complete the process.