Simple Firmware Upgrade-M501 doesn't show setting properly

Simple Firmware Upgrade-M501 doesn't show setting properly

Postby Vapor » 2014-Aug-Fri-11-Aug

So I have been trying to upgrade my firmware on my bot after installing the level probe. I think it's the 1401 model.


Anyhow, when I start it up and check locations m501 shows that they're all at 0.

I job the axis around a bit and try m501 and they're still showing all 0.

I set them to random numbers. I come back and try to check them and they're all showing the exact numbers I changed.

I try to home and X homes, Y crashes into the back instead of moving forward to the end stop switch. Z just goes up a little ways and stops. It's almost like the direction is backwards on it as well.

I've tried about 6 different firmwares that say they should work, but theyr'e all doing the same stuff.

When I home, it moves fast like it should when jogging. When I try to jog an axis, it SLOWLY goes into place.


Have I gone dumb? What am I doing wrong or missing. I've not found any really good information about the firmware upgrade. I think I'm missing something key that I'm overlooking, but I've had it with this thing for now.

Please Help!
  • 0

Vapor
Levelling print bed...
 
Posts: 41
Joined: 2014-Mar-Sat-18-Mar
Reputation: 0

Simple Firmware Upgrade-M501 doesn't show setting properly

Sponsor

Sponsor
 

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

Postby RetireeJay » 2014-Aug-Fri-15-Aug

The information at these links may help you to understand what's going on with M500, M501, etc.
viewtopic.php?f=18&t=2763
http://www.printrbottalk.com/wiki/index ... are_Update
  • 0

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
"My next printer is..." Prusa i3 MK3
User avatar
RetireeJay
My next printer is...
 
Posts: 4941
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 496

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

Postby Vapor » 2014-Aug-Fri-23-Aug

Thanks, but I know how to go through the process of upgrading the firmware. I'm familiar with gcode as I have a CNC mill.

My main problem is I don't know which version of the firmware may work without reversing my axis.

Along with that, I'm following the commands Brook shows in his probe setup video and my settings don't show what he says they are. Mine stay static, while hid are changing, telling him how to tweak in the probe.

I'm going to try it work as fresh head in the morning, but I still would like to think there is a firmware out there that should work without reversing things, I just don't know how to find it.

Thanks everyone!
  • 0

Vapor
Levelling print bed...
 
Posts: 41
Joined: 2014-Mar-Sat-18-Mar
Reputation: 0

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

Postby Mooselake » 2014-Aug-Fri-08-Aug

When you updated the firmware you lost your saved calibration numbers (I'm assuming all zeros refer to your saved numbers), so you'll need to recalibrate. Hopefully you wrote them down before reflashing.

Depending on your model bot you might need to reverse a motor connector - printrbot's trying to standardize the firmware and eliminate versions for different models. It's a one time thing, and has been discussed several times; try a forum search.

Good luck!
Kirk
  • 0

Modified KickStarter Classic Plus 7/2012
KS Thingybot Delta Pro 10/31/16
User avatar
Mooselake
My next printer is...
 
Posts: 3591
Joined: 2011-Dec-Tue-23-Dec
Location: Moose Swamp, Upper Michigan, USA
Reputation: 172

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

Postby Mooselake » 2014-Aug-Fri-08-Aug

What kind of CNC mill? Parallel port or USB controller? Control software?

Kirk
  • 0

Modified KickStarter Classic Plus 7/2012
KS Thingybot Delta Pro 10/31/16
User avatar
Mooselake
My next printer is...
 
Posts: 3591
Joined: 2011-Dec-Tue-23-Dec
Location: Moose Swamp, Upper Michigan, USA
Reputation: 172

Re: Simple Firmware Upgrade-M501 doesn't show setting proper

Postby bbrown64 » 2015-Jul-Thu-10-Jul

I just flashed my firmware. I have the PB SM 1403. You can find the correct firmware at http://help.printrbot.com/Guide/How+to+Reflash+Firmware/78 Scroll down toward the bottom on the right side. You will see a short list of the models of Printrbot. Select the firmware that matches your model. Then Follow the instructions on that same page on how to flash your firmware. It only takes about 10 minutes or less to complete the process.
  • 0

Bill Brown
Tulsa, OK
User avatar
bbrown64
Layer 300 of 1234
 
Posts: 308
Joined: 2015-Mar-Thu-14-Mar
Reputation: 5


Return to Simple talk (software)

Who is online

Users browsing this forum: No registered users and 1 guest