[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4693: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4695: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4696: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4697: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Printrbot Talk Forum • View topic - Simple Metal X and Y Axes Alignment Print

Simple Metal X and Y Axes Alignment Print

Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Mon-22-Jun

I was experiencing layer staggering for prints over 143mm X/Y, and I think I discovered the issue. The printrbot Simple homes at X0 and Y0, however it begins printing at approximately X7.5mm and Y7.5mm. To calculate this, I made a 149mm alignment square. It begins drawing the line on the left back side around 7.5mm when it should start it at .5mm. Then it grinds out when it gets to the right side, causing the next left side line to be staggered by 7.5mm. Same thing happens with Y axis.

Can some people on here download this alignment test and try it out on their Simple Metals? I suspect it's an issue with the firmware (I'm using V3), but that obviously won't be the case if I'm the only one with the issue. By the way, changing Repetier Printer Settings and the centering in Slic3r does absolutely nothing.

I'm too new a user to post links, so search Thingiverse for thing #358689 or "Printrbot Simple Metal Alignment Test."
  • 0

tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1

Simple Metal X and Y Axes Alignment Print

Sponsor

Sponsor
 

Re: Simple Metal X and Y Axes Alignment Print

Postby Yakeru » 2014-Jun-Wed-15-Jun

Hi,

Same issue here with the v2 firmware.
The answer was found here : [oops, no URL allowed for me] "Bad firmware? M212 not working properly..." on the offcial printrbot's help.
The probe offset defined with M212 is responsible, apparently it messes up with a general offset.

So if you have M212 X20 Y0 Z[your calibration], for some reason it will cause the issue you described.

By changing to M212 X0 Y0 Z[your calibration], it resolves that issue, I was able to print a 6"x6" object.

But I suspect that the auto leveling won't be as good, since the offset of the probe is not taken into account anymore ... we have to wait for a new firmware I suppose.
  • 1

Yakeru
Loading filament...
 
Posts: 11
Joined: 2014-Mar-Mon-08-Mar
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Wed-17-Jun

Ah, good catch! My M212 does have X at 20mm. But I wonder why the Y is doing the same thing? (My Y is at 0 as your example.)

I'm guessing the probe offset won't be an issue. Has anyone tested this?
  • 0

tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby JBallard86 » 2014-Jun-Thu-09-Jun

I have had my m212 set to: M212 X0.00 Y0.00 Z-2.05 since day 1.

what i think you should look at are the following:
Home offset (mm):
M206 X0.00 Y0.00 Z0.00
Min position (mm):
M210 X0.00 Y0.00 Z0.00
Max position (mm):
M211 X152.40 Y152.40 Z152.40

min position was at x5 y5 when i got the printer. These are my settings and seam to work for me.

remember you can also change settings in your start.gcode and change them back before a print starts.
  • 1

JBallard86
Loading filament...
 
Posts: 16
Joined: 2014-May-Mon-17-May
Reputation: 4

Re: Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Thu-12-Jun

Thanks! I will try these things and report back.
  • 0

tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby Yakeru » 2014-Jun-Thu-18-Jun

Hi,

In my case, setting M212 at X0 Y0 Z... alows me to print 6"x6" objects, but I can clearly see that it affects the Z calibration : My Z gets to low on the left, almost clogging the nozzle, and to high on the right.
So I have to chose between having a good calibration, or being able to print 6"x6" ...

I verified the M206, M210 and M211 values, and they are all correct.

The G29 has a strange behavior, I don't understand the logic behind it, I will open a new topic about that ...
  • 0

Yakeru
Loading filament...
 
Posts: 11
Joined: 2014-Mar-Mon-08-Mar
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Thu-19-Jun

JBallard86, my M206, M210 and M211 values were also as you wrote them. Those are the defaults.

Is it possible to use start.gcode to go from M212 X20.00 when leveling to M212 X0.00 when printing? Or do we have to wait for a bios update?
  • 0

tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby JBallard86 » 2014-Jun-Thu-20-Jun

there is a new firmware release from the 5th of this month its on the simple main page of the printrbot site (i cant post links)

G29 works fine for me, I have found that you always need to run g28 before running g29. my homing sequence is as follows:

G28
G X0 Y140
G29

I found with trial and error that I got random results if I didnt do it in that order.
  • 0

JBallard86
Loading filament...
 
Posts: 16
Joined: 2014-May-Mon-17-May
Reputation: 4

Re: Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Thu-21-Jun

Thanks for the start code! I will try that.

Setting M212 to X0.00 lets me print 150mm (on BOTH X and Y axes, scratching my head as to why), however, like Yakeru stated, it does gum up the leveling.

Re: the new firmware, I'm holding off on it. Not sure even Printrbot stands behind it, as this Twitter conversation illustrates:

Printrbot Support ‏@support_pb: (June 6) "METAL SIMPLE OWNERS: Sorry for the firmware fail yesterday. Take 2. Updated yet again today on http://Printrbot.com/simple ...thanks!"

(Firmware they linked to was labeled version three with a modification date of May 8th, not June 5th.)

Tony Youngblood ‏@tonyyoungblood: "@support_pb Wait, I thought V3 was the one from a month ago. Shouldn't this be V4? Or is it the one from a month ago?"

Joel Crane ‏@FuelCell250: "@tonyyoungblood @support_pb I think it's v4. Working on getting that info sorted out. :)"

Printrbot Support ‏@support_pb: "@tonyyoungblood @lewis_i here, Firmware naming under review at this moment, please bear with us while we sort it... https://"

Tony Youngblood @tonyyoungblood: "@FuelCell250 @support_pb The date modified still says May 8th though."

I haven't heard back from them since.
  • 0

Last edited by tonyyoungblood on 2014-Jun-Thu-22-Jun, edited 1 time in total.
tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Thu-21-Jun

Jballard,

It appears I already had G28 in my start code. What I have is what Printrbot recommends:

G28 X0 Y0;
G29;
G1 Z5 F5000;

What's the advantage of Y140 over Y0?
  • 0

tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby JBallard86 » 2014-Jun-Thu-22-Jun

  • 1

JBallard86
Loading filament...
 
Posts: 16
Joined: 2014-May-Mon-17-May
Reputation: 4

Re: Simple Metal X and Y Axes Alignment Print

Postby JBallard86 » 2014-Jun-Thu-22-Jun

  • 0

JBallard86
Loading filament...
 
Posts: 16
Joined: 2014-May-Mon-17-May
Reputation: 4

Re: Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Thu-23-Jun

Thanks, JBallard86.

It sounds like what I have basically does the same thing (for the firmware I have).

I'm going to hold off on downloading the new firmware until they get it "sorted out."
  • 0

tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1

Re: Simple Metal X and Y Axes Alignment Print

Postby tonyyoungblood » 2014-Jun-Thu-23-Jun

The firmware on the Printrbot Simple page they linked to on June 5th now has the updated firmware on it. http://printrbot.com/simple/

However, on the day they tweeted it, that page still linked to the V3 firmware. Hence my confusion. I just don't think they realized it linked to the old firmware at the time of my tweet. Which explains why their reply didn't address the basic question, "Is this firmware from a month ago or is it new?"
  • 0

tonyyoungblood
Loading filament...
 
Posts: 21
Joined: 2014-Apr-Tue-13-Apr
Reputation: 1


Return to Simple talk (software)

Who is online

Users browsing this forum: No registered users and 2 guests

cron