Problem with Simple XL

Problem with Simple XL

Postby Harebourg » 2014-May-Fri-14-May

Hi everyone,

today i have home made a printrbot XL upgrade, here is a picture :

Image

All hardware part look work great but when i try to move the X axis on the simple the motor look to stop at 100mm here is a video :

https://www.youtube.com/watch?v=PulrwIqHVXw

So, anyone can tell me what ? Here is my config :

Image

and my "M505"

Image

I have try resize my bed in the firmware on the Printrboard with :

M211 X153 Z165

M500

But nothing change ! If anyone can help me it's would be awesome... Have a nice day all ! :D
  • 0

Harebourg
Loading filament...
 
Posts: 17
Joined: 2013-Aug-Fri-07-Aug
Reputation: 0

Problem with Simple XL

Sponsor

Sponsor
 

Re: Problem with Simple XL

Postby RetireeJay » 2014-May-Fri-14-May

There are a couple of tricks about that M211 command.

First, if you issue the M211 command to change the maximum dimension of an axis, then you need to follow that with a "home" command. Otherwise the old limit stays in effect, even though an M503 will tell you the new value is in effect.

Second, the M211 command changes the maximum dimension only temporarily, in "Active Values" memory. In order to make it permanent, before you turn off the printer, you need to follow up with an M500 command to store the new values in EEPROM. After you do this, then the maximum dimensions will be correct every time you turn on the printer.
  • 0

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
User avatar
RetireeJay
My next printer is...
 
Posts: 4778
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 477

Re: Problem with Simple XL

Postby Harebourg » 2014-May-Fri-15-May

RetireeJay wrote:There are a couple of tricks about that M211 command.

First, if you issue the M211 command to change the maximum dimension of an axis, then you need to follow that with a "home" command. Otherwise the old limit stays in effect, even though an M503 will tell you the new value is in effect.

Second, the M211 command changes the maximum dimension only temporarily, in "Active Values" memory. In order to make it permanent, before you turn off the printer, you need to follow up with an M500 command to store the new values in EEPROM. After you do this, then the maximum dimensions will be correct every time you turn on the printer.



So, i put :

M211 X400 Z100
(push home)
M500

It's right ?

Thanks for your rapid response <3
  • 0

Harebourg
Loading filament...
 
Posts: 17
Joined: 2013-Aug-Fri-07-Aug
Reputation: 0

Re: Problem with Simple XL

Postby RetireeJay » 2014-May-Fri-15-May

Harebourg wrote:So, i put :

M211 X400 Z100
(push home)
M500

It's right ?


I think so. Let me see if I am understanding you correctly; this is what you should do:

M211 X400 Z100 (click the "Send" button)
Click the "Home" buttons for X and Z (or click the global "Home" button)
M500 (click the "Send" button)

Actually the homing and the M500 can be done in either order.

:)
  • 0

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
User avatar
RetireeJay
My next printer is...
 
Posts: 4778
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 477

Re: Problem with Simple XL

Postby Harebourg » 2014-May-Fri-15-May

Just try this and nothing change... Where the hell that problem come from !?
  • 0

Harebourg
Loading filament...
 
Posts: 17
Joined: 2013-Aug-Fri-07-Aug
Reputation: 0

Re: Problem with Simple XL

Postby evanalmighty » 2014-May-Fri-15-May

It should be M211 X185 Z165
  • 0

User avatar
evanalmighty
Layer 650 of 1234
 
Posts: 689
Joined: 2014-Feb-Mon-15-Feb
Location: Irvine, CA
Reputation: 45

Re: Problem with Simple XL

Postby Harebourg » 2014-May-Fri-15-May

evanalmighty wrote:It should be M211 X185 Z165


It's not the official XL upgrade, i can print more than 400mm on mine :) (in theory for the moment..)
  • 0

Harebourg
Loading filament...
 
Posts: 17
Joined: 2013-Aug-Fri-07-Aug
Reputation: 0

Re: Problem with Simple XL

Postby RetireeJay » 2014-May-Fri-16-May

Looking at your query output I don't see any mention of M211. Perhaps you are not using an up-to-date firmware. Older versions of the firmware did not have the M211 command implemented.

You can use the Unified V2 or V3 firmware to have M211 implemented. Instructions for flashing your firmware are in the Wiki (red-white-beige button next to the "search" window on this screen). You can find links to the Unified software by searching on this forum. The Unified hex file will be found on Github, but Github is hard to search.
  • 0

Printrbot Plus operational January 2013
Brass threaded rods (5/16" X 18) & nuts for Z axis
GT2 belts & pulleys
Cable chain to reduce probability of fatigue failure in wires
E3D V5 Hot End, 0.4mm nozzle, also 0.8 and 0.25 in use occasionally
PB fan mount + 40mm fan -- using printed mount adapter, not the E3D supplied fan
Injection molded extruder gears
Optical Z "endstop" (custom designed and built)
Have used many pounds of T-Glase filament. Now also doing some work with Ninjaflex SemiFlex
Print on glass with Scotch Craft Stick or other glue stick
User avatar
RetireeJay
My next printer is...
 
Posts: 4778
Joined: 2013-Jan-Wed-13-Jan
Location: Greenville, SC
Reputation: 477

Re: Problem with Simple XL

Postby Harebourg » 2014-May-Sat-03-May

Hi everyone, i just update the firmware with unified V2 and... THAT WORK ! :mrgreen:
BUT, now i have a new problem; the extruder dont work in the good way, it's retract the filament (he turn in the wrong way)
here is my M501 : Image

If you see where is the problem ?

Thanks again all <3
  • 0

Harebourg
Loading filament...
 
Posts: 17
Joined: 2013-Aug-Fri-07-Aug
Reputation: 0

Re: Problem with Simple XL

Postby Some Printr Noob » 2014-May-Sat-03-May

Harebourg wrote:Hi everyone, i just update the firmware with unified V2 and... THAT WORK ! :mrgreen:
BUT, now i have a new problem; the extruder dont work in the good way, it's retract the filament (he turn in the wrong way)
here is my M501 : Image

If you see where is the problem ?

Thanks again all <3


Flip the extruder motor plug. it will run the other way.
  • 0

Some Printr Noob
Layer 300 of 1234
 
Posts: 327
Joined: 2014-Jan-Tue-00-Jan
Reputation: 22


Return to Simple talk (hardware)

Who is online

Users browsing this forum: No registered users and 2 guests