[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4693: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4695: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4696: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4697: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3823)
Printrbot Talk Forum • View topic - Mintemp Problems. Help Please!

Mintemp Problems. Help Please!

Mintemp Problems. Help Please!

Postby Some Printr Noob » 2014-Feb-Sat-01-Feb

It's been a week since I built my Printrbot Simple. I was printing some stuff, and then it decided to suddenly stop with a Mintemp error.

I get Mintemp errors and "Line Number is not Last Line Number+1" error things.

I've tried/checked:
-Reflashing the Printrboard
-Checking all connections (pics show connections after I unplugged end stops; I've triple checked pretty much all the connections from the hotend to the board, and also unplugged others in an attempt to isolate the problem. The hotend stays cold even I try to heat it.
-I'm located in California. My room is around 60-70f.

I don't know what's wrong :(. Any help?

[Your post looks too spamy for a new user, please remove off-site URLs.]
Remove spaces in the links below :/

htt p://i.imgur. com/lFy0ELE.jpg
htt p://i.imgur. com/Smx47Hj.jpg
htt p://i.imgur. com/XsdMKSx.jpg

htt p://youtu. be/8HFNLTt4nrU
  • 0

Some Printr Noob
Layer 300 of 1234
 
Posts: 327
Joined: 2014-Jan-Tue-00-Jan
Reputation: 22

Mintemp Problems. Help Please!

Sponsor

Sponsor
 

Re: Mintemp Problems. Help Please!

Postby plexus » 2014-Feb-Sat-02-Feb

check the connectors to the hot end thermistor. its possible the thermistor failed due to electrical or mechanical stress. do you have an multimeter? measure the resistance of the thermistor. you should get a value. a break would be infinite or no reading. you can order a new thermistor from ebay search the forum for the type needed. you will have to take the hot end apart carefully and replace the thermistor. again somewhere on the forum someone might have talked about it. search first and if not post a thread and people can help you.

I know it sounds arduous but its all part of getting into this bleeding edge technology. its all one great big experiment.
  • 0

User avatar
plexus
Site Admin
 
Posts: 2117
Joined: 2011-Dec-Mon-16-Dec
Location: Toronto, Canada
Reputation: 95

Re: Mintemp Problems. Help Please!

Postby jeromedayton » 2014-Feb-Sat-02-Feb

Some printr noob-

I've been chasing the same problem for three weeks after successfully printing for three weeks before that with my new simple. In my case the temperature would rise nicely to operating temp in then at some point during the print, I would get the min temp error ( sometimes but not always with a zero temp also being reported) and I would have to kill the print.

I finally traced my problem down to a broken wire in the board to thermistor connector resulting in an open circuit. It would fail intermittenly before it finally failed hard. You should be seeing about 100k ohms across the thermistor connectors at room temp if all is good. Resistance will go down as temp goes up.

Normally the thermistor should be reporting a room temperature of around 25 Celsius when you first connect. If you are seeing a temp of zero, it is because there is an open thermistor circuit. I put in diagnostic code in the firmware and confirmed that the printrboard was seeing a temp of 0 and that the min acceptable temp is 5 Celsius. The min tmp check is there because if there is a break in the thermistor circuit the board will think the extruder temp is 0 Celsius, and otherwise result in in the extruder being fully powered in an attempt to get the hot end up to temperature, a potentially dangerous situation.

I'm waiting for a replacement connector from printrbot and will report back after i've installed it.

I believe the break may have resulted from my y-axis motor rubbing against the thermistor and fan wires. I have since flipped the board around (now faces out) to try and eliminate the problem in the future AND make it easy to work on the board.
  • 0

Jerome
Retired Software Developer
Printrbot Simple operational since Xmas 2013
Printrbot Jr v 2 with alu extruder March 2014
User avatar
jeromedayton
Waiting for extruder temp...
 
Posts: 82
Joined: 2014-Jan-Fri-15-Jan
Reputation: 2

Re: Mintemp Problems. Help Please!

Postby Some Printr Noob » 2014-Feb-Sat-02-Feb

  • 0

Some Printr Noob
Layer 300 of 1234
 
Posts: 327
Joined: 2014-Jan-Tue-00-Jan
Reputation: 22

Re: Mintemp Problems. Help Please!

Postby Some Printr Noob » 2014-Feb-Sat-04-Feb

If I'm doing this right:
White is negative and Black is positive. DCV goes the right way when I measure it like this. I switch it to Rx100, and gete a reading of 1, so that should be 100 ohms, right?

So that means that the circuit should still work. I'm really confused now.
  • 0

Some Printr Noob
Layer 300 of 1234
 
Posts: 327
Joined: 2014-Jan-Tue-00-Jan
Reputation: 22

Re: Mintemp Problems. Help Please!

Postby jeromedayton » 2014-Feb-Sat-09-Feb

  • 0

Jerome
Retired Software Developer
Printrbot Simple operational since Xmas 2013
Printrbot Jr v 2 with alu extruder March 2014
User avatar
jeromedayton
Waiting for extruder temp...
 
Posts: 82
Joined: 2014-Jan-Fri-15-Jan
Reputation: 2

Re: Mintemp Problems. Help Please!

Postby jeromedayton » 2014-Feb-Sat-14-Feb

Woohoo success. My replacement cable for the thermistor came in the mail today. I connected it up and no more Min Temp problems!!!
  • 0

Jerome
Retired Software Developer
Printrbot Simple operational since Xmas 2013
Printrbot Jr v 2 with alu extruder March 2014
User avatar
jeromedayton
Waiting for extruder temp...
 
Posts: 82
Joined: 2014-Jan-Fri-15-Jan
Reputation: 2

Re: Mintemp Problems. Help Please!

Postby Some Printr Noob » 2014-Feb-Sat-19-Feb

  • 0

Some Printr Noob
Layer 300 of 1234
 
Posts: 327
Joined: 2014-Jan-Tue-00-Jan
Reputation: 22

Re: Mintemp Problems. Help Please!

Postby Some Printr Noob » 2014-Feb-Sat-19-Feb

  • 0

Some Printr Noob
Layer 300 of 1234
 
Posts: 327
Joined: 2014-Jan-Tue-00-Jan
Reputation: 22

Re: Mintemp Problems. Help Please!

Postby jeromedayton » 2014-Feb-Sat-21-Feb

  • 0

Jerome
Retired Software Developer
Printrbot Simple operational since Xmas 2013
Printrbot Jr v 2 with alu extruder March 2014
User avatar
jeromedayton
Waiting for extruder temp...
 
Posts: 82
Joined: 2014-Jan-Fri-15-Jan
Reputation: 2


Return to Simple talk (hardware)

Who is online

Users browsing this forum: No registered users and 1 guest