#SETBACKS! Fried Rev. 4 printrboard need help

#SETBACKS! Fried Rev. 4 printrboard need help

Postby Flordonwrath » 2018-Apr-Sat-09-Apr

So I got a printrbot simple metal off chico state university already used for a semester or two. When I got it, it was dis-assembled (thumbs up) and half of the parts were missing. I dove in, I'm so infatuated with 3d printing and everything about it! Only problem is I live in a shed with epilepsy fighting the government for money. So 3d printing isn't something I can just afford. Anyways I pulled an at out of an old Dell and hooked it up to my Rev. 4, same board that came with it from the university. It worked fine, got my heat bed up to 73'c and my extruder pumpin out abs. So I figured , I'm so close to having this done, to where there is no more fixing, just upgrading! So I took it all apart and cleaned it all up made sure everything was tight and made a list for everything missing, screws, that's all I'm missing. Well as I'm tidying up I got to plug it in to make sure it's still got power and the atx psu fried, along with the rev. F4 board... Now I'm stuck and have no idea what to do. Do I get another rev. F4 board? Cause I can't find one, or do I upgrade? And if I upgrade can anyone show me to a cheap reseller? I worked far to long and hard creating with only the dirt under my nails for this to go unfinished! Thank you all so very much!

Sent from my SM-G950U using Tapatalk
  • 0

Flordonwrath
Loading filament...
 
Posts: 13
Joined: 2018-Apr-Sat-06-Apr
Reputation: 0

#SETBACKS! Fried Rev. 4 printrboard need help

Sponsor

Sponsor
 

Return to Simple talk (hardware)

Who is online

Users browsing this forum: No registered users and 1 guest