[Solved] Be careful of Repetier 0.90C

Post a reply

Smilies
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode is ON
[img] is ON
[flash] is OFF
[url] is ON
Smilies are ON
Topic review
   

Expand view Topic review: [Solved] Be careful of Repetier 0.90C

Re: [Solved] Be careful of Repetier 0.90C

Post by JonS » 2013-Sep-Sat-15-Sep

Clicking on the "OK" button in the manual control button also resolves the problem.

Re: Be careful of Repetier 0.90C

Post by vw1610 » 2013-Sep-Sat-14-Sep

davec wrote:RJ, on Repetier 0.90C, under the Config, Printer Settings - 'Reset on Connect' change to disabled. That seems to have worked for me. I've been busy and haven't printed anything yet with the new version, but can home all axis and extruded.
Dave



This worked for me :)

Re: [Solved] Be careful of Repetier 0.90C

Post by JasperJ » 2013-Jul-Mon-00-Jul

Arduino repurposed the DTR line on their usb to rs232 chips a couple years back to implement a PC-triggered reset, for the purposes of uploading software.

Re: [Solved] Be careful of Repetier 0.90C

Post by ei8htohms » 2013-Jul-Fri-17-Jul

Ah, good to know. Had trouble getting commands to go through after the update and didn't know why. Sending commands from the LCD encoder seemed to snap the bot (host) out of it but had no idea why.

Re: Be careful of Repetier 0.90C

Post by RetireeJay » 2013-Jul-Wed-08-Jul

OK, the solution is available. Here's how to do it.
1) click on the "Printer Settings" icon in the upper right. (The Config: Printer Settings will be disabled if you have the problem)

PrinterSettingsButton.JPG


2) In the window that comes up, look at the line for "Reset on Connect" - it probably has some settings about "DTR." That's "Data Terminal Ready" - ancient technology for establishing "ready or not ready" conditions for the RS-232 lines connecting "teletypes" to "modems" that worked over copper wire "phone lines." I have no idea why they would be using DTR on a USB serial connection. If the supposed DTR signal is not in the right state, then communications won't happen. But our communication is using USB, so just set it to "Disabled"

PrinterSettingsScreen.JPG

Re: Be careful of Repetier 0.90C

Post by phil_roberts » 2013-Jul-Tue-22-Jul

Thanks! I was having trouble connecting. This fixed it.

Re: Be careful of Repetier 0.90C

Post by davec » 2013-Jul-Tue-14-Jul

RJ, on Repetier 0.90C, under the Config, Printer Settings - 'Reset on Connect' change to disabled. That seems to have worked for me. I've been busy and haven't printed anything yet with the new version, but can home all axis and extruded.
Dave

[Solved] Be careful of Repetier 0.90C

Post by RetireeJay » 2013-Jul-Tue-14-Jul

I've been delighted using Repetier 0.90B, because of the wonderful new tools like EEPROM configuration and calculators for calibration.

But today I downloaded Repetier 0.90C, and it is broken on my system. I had to revert to 0.90B.

I'm running Windows 7, and a Printrboard Rev D board with the original software. When I connected using Repetier 0.90C, the "connect" button turned green, but that's about the only thing that happened. Repetier said that 6 or 7 commands were waiting. It failed to download any info from the board, so it didn't have the EEPROM configuration available; it didn't even know if it was a Marlin board or whatever. (I never even tried to home an axis or anything like that).

Reverted to Repetier 0.90B and found joy again. :D

Top

cron